Unable to install Webroot, no response from support ticket or phone line.

  • 23 September 2020
  • 7 replies

I purchased the Webroot SecureAnywhere online 6 days ago, but did not receive a keycode. It may be possible that I entered my email address incorrectly when purchasing.

Within a few minutes I opened a support ticket and submitted a request 3 times, but no response. I called the Webroot support numbers in the US and also 2 other countries, and spent at least 45 minutes on hold, but the calls are not answered. I have tried the “redownload / get keycode” option on the website several times, but this does not work.

I have made a purchase, but I can not install the product as I did not receive the keycode.

I would appreciate if someone could assist.


Best answer by khumphrey 24 September 2020, 00:43

View original

7 replies

Userlevel 7
Badge +62

Hello @lt2020 

Welcome to the Webroot Community,

So sorry to hear you are having these issues. I will ping our Community Specialist  @khumphrey to see if he can help you resolve this by getting you help from the Webroot Support Team.



Thank you.

Userlevel 7
Badge +62

You are most welcome. @khumphrey should be responding to you today sometime. Hopefully? :wink:

Userlevel 7
Badge +20


Sorry for the late response! I have a few responses regarding what you posted.

  1. Please refrain from sending multiple tickets before receiving a response from support. This pushes your response to the bottom of the queue and makes it take longer for support to get back to you - that’s why you haven’t gotten a response yet.
  2. How did you purchase the key code? Through Webroot’s website, directly? Through Amazon? BestBuy?
  3. If you purchased through Webroot directly, please contact this office as they’ll be able to help you out far quicker than the tech support team:



Hope that helps! 

Userlevel 7
Badge +62

Thank you @khumphrey 😉

I purchased the software online through the Webroot website.

I contacted the sales team by phone, they were able to resolve the issue and sent me the keycode - it appears I made a spelling mistake on my email address that I entered when purchasing.

Thank you very much for the help, much appreciated. The product is now installed and working.

Userlevel 7
Badge +63

Great to hear your issue is Solved!