Webroot is blocking my internet

  • 21 February 2015
  • 1 reply

Webroot appears to be blocking my internet on my Windows 8 (chrome and ie) laptop. I have Internet on all of my mobile devices. If I turn off webroot I can at least access google, but no links from any search pages. Help!

1 reply

Userlevel 7
Hi wmfinn
Welcome to the Community Forums.
This is not at all normal and I belieev that the best thing to do in this case is to unistall/clean install to make sure that the issue is not due to a faulty installation.
.  Do this by:
  • Make sure you have a copy of your Keycode
  • KEEP the computer online for Uninstall and Reinstall to make sure it works correctly
  • Download a Copy Here (Best Buy Subscription PC users click HERE)
  • Uninstall WSA and Reboot
  • Install with the new installer, enter your Keycode and don't import any settings as you can set it up as you like once it's done
  • Let it finish it's install scan
  • Reboot once again
If this fails to resolve the problem, you may need to contact Support for assistance.
If your subscription is directly through Webroot, you will need to contact Webroot Support.  You can do so by submitting a Support Ticket if you have not already done so, or by phone during business hours.  (The online Ticketing system is manned 24/7)
If your subscription is through Best Buy Subscription Software services, you may need to call them at 1-800-GEEK-SQUAD.
Do come back and let us know either way whether this works for you.
Regards, Baldrick