Webroot crashing on scanning sdcard

Xoom Wifi. Webroot always worked normally. Since a while Webroot scans normally just up to sdcard, then it freezes, then after some time it crashes. I removed the external sdcard to see if that caused it but that didn't make difference. Obviously i can't remove the internal memory.

Best answer by JimM 23 February 2013, 00:57

View original

18 replies

Userlevel 7
Welcome petrossa :D
Thank you for joining our Community! I would like more information from you on what version of the software you are on and which app you are using. Please follow the instructions below and let me know your findings!
1. Open the Webroot Mobile App
2. At the home screen, press your Android menu button
3. Press "About"
What is the name of the software app installed and what is the version number?
Also, are there any other security software or task killer apps installed on this device?
hia Mike, It's Webroot SecureAnywhere Mobile version:, defusion set 256 No task killer apps running. No other security software i know of.
Userlevel 7
Hi petrossa,
I encourage you to refer to this thread on a similar issue with the Motorola Xoom and an Archose tablet. Just to clear things up, is your device rooted?
You are on the most current version of the software and definitions so I am wondering if a firmware update is needed on your device? You can contact your service provider or Motorola support to figure out if that is a possible cause.
If a firmware update does not fix the issue, I will be able to further assist if you submit mobile logs. I have listed the steps to do this below!
1.  Replicate the issue you have been experiencing.  Be sure to do this immediately before following the rest of these steps.
2.  Open the Webroot SecureAnywhere Mobile app
3.  From the main screen of the Webroot app, tap the Android Menu button
4.  Tap General Settings
5.  Tap Support Options
6.  Tap Collect and mail logs
7.  Mail these logs: Please see PM for e-mail address to send logs to
Read thread, my firmware is 4.04 since some time now.
Secureanywhere service hogs the cpu for about 6 minutes then stops. The app still indicates i need to a scan.
Screenshot of service state: 
Logs sent. 
Userlevel 7
Hi petrossa,
You confirmed that the requested logs had been sent, however, I have not received them yet and we tested the address to make sure it was functioning correctly. Would you mind repeating the steps I had previously mentioned?
Please be sure to recreate the scanning issue right before gathering the logs! I will also send you another private message with the email address.
Thank you for your patience 😉
weird. Ok. will repeat.
Userlevel 7
Very innovative with the Dropbox!
Thank you for getting the logs to us. We did find that you are experiencing an out-of-memory issue with the software as well as other programs. The screenshot also helped me notice that you have quite a few apps running. :robotsurprised:
We are going to have development look at this but in the short-term, please try shutting down some of the unnecessary apps that may be running and then try to perform a scan!
I look forward to hearing the results.
It has 1 gb of memory. Normally I have around 400 mb free when all is loaded. Anyway I killed some stuff but same result. Doubt memory could be an issue not many phones with even have half that
Userlevel 7
The logs collected so far indicate that this is most likely an out of memory issue.
This is not a reflection on how much memory you have total but rather how Java is handling that memory on your device. However, since the log segment cuts off prior to the crash, we cannot be positive in this diagnosis.
It appears the logs were gathered too late after the crash for the crash itself to appear in the logs. Please collect another set, and we will continue to investigate.
It is imperative you collect the log immediately after reproducing the issue.
Ok. Will try again. The memory issues might be due to a badly written app. Have to check that out one day, doesn't seem to bother the tablet much. I have no other issues except this scanning thingie. Anyroad it works fine on my Samsung Galaxy with hardly 50 mb memory left and an autokiller/memory cleaner installed.
Userlevel 7
Thank you again Petrossa,
It is still looking to be an out-of-memory error. It is being caused by how Java is handling memory allocation on the device.
The issue has been submitted to development for review because it is something we may be able to code around. :robothappy:
Okay. I guessed as much from the logs. It takes longer to unfreeze the more memory is free. This run took several minutes to finally crash. If I load it up the scan stops within just a minute or two. Hope you can get it running. It scans fine on new installs so I can wait.
Userlevel 1
I seem to be having the same issue. I have the largest memory card available, & it is well used. Lol.

The scan often causes my phone to reboot if I try to leave the scan screen. The scan veritably flys when not scanning the memory card. If I leave it alone, it will resolve itself, eventually. Often the memory card part of the scan alone takes upwards of half an hour!

After reading this thread, I doubt I could capture the logs in a timely enough fashion to be of much use. During the memory card scan, my phone is completely unusable, & there is no way to pause or stop the scan. I can't even leave the scan screen to kill other processes. Webroot completely ties up the processor.

I've do have a task killer, but Webroot is on the safe list. I've disabled it, turned off everything Google will allow me to (not rooted), same result.

I have an Alltel Motorola Milestone X (same as Verizon Droid 😵 Running Gingerbread 2.3.5. "Webroot Secure Anywhere" is my only Antivirus App. I got it from Google Play, & it is up to date.

Idk what to do. If I could set the "scheduled" scan time manually, I think I could cope fine. I even checked to see if the Premiere version had this ability, but it appears not. I AM using the free version, & up until the last couple updates, the problem was much less pronounced, & I was willing to put up with the lag it causes during the scans. Now, however, it is worrisome because it likes to run when I need my phone operational. I'm a second/third shift worker who drives at night A LOT.

Any suggestions? Better yet, any plans to add the ability for the user to set the run time for the scan? 10am, when I'm sound asleep would be ideal.

Another thought, because of the lag, I changed to the weekly scan. If you think it may help, I'll change it to daily. Maybe the time between scans makes a difference? I really don't want to have to abandon Webroot. I DO feel safer with it.

Userlevel 7
Jem126, welcome to the Community and thank you for chiming in!
I would love to get mobile logs from you immediately after running a scan. I know it is time consuming and tedious, but the more information we have from our customers the better.
Development is taking this issue seriously and your input helps!
1. Replicate the scan issue and be sure to do this immediately before following the rest of these steps.
2. Open the Webroot SecureAnywhere Mobile app
3. From the main screen of the Webroot app, tap the Android Menu button
4. Tap General Settings
5. Tap Support Options
6. Tap Collect and mail logs
7. Mail these logs: Please see PM for e-mail address to send logs to and please let me know when they have been sent
Your request for a specific run time for a scan would be a perfect idea for our Ideas Exchange! It will gain more attention as it gains Kudos and popularity. 😃
Jem126, you could try to kill the app in midsession as soon as it starts hanging on the sdcard.. Since it only is busy allocating memory in a loop letting it run it's course and then having your device crash is not very useful. At least you'll have some logs to send. Just an idea.
Userlevel 1
The only reason I thought I wouldn't be able to get the logs is because of the device locking up. If the phone reboots, would there even be anything useful to send?

I'll see what I can do.
Thanks... both of you. 🙂
When you reboot logs are emptied. Try the app: Lumberjack.
It can export on the go, even to a cloudstorage. Start lumberjack, start Webroot. Then export in lumberjack the logs as soon as Webroot hits sdcrad scanning. That way some action can be recorded. Play with it to see where it still functions and where not.
Userlevel 7
Sorry to dredge up a really old topic, but I was doing some cleanup and it occurred to me that not everyone may be aware that this issue was fixed.  It was actually fixed back in December.  Details are available here.  For those of you subscribed to this topic, this is some very late, but probably very welcome, good news.  🙂