Webroot Password manager no longer works anywhere!

  • 13 January 2019
  • 28 replies

Show first post

28 replies

Userlevel 3
Badge +11
Okay... so I get you're angry (three posts in a row) and that you "paid for" all the features but are not "receiving" all of them. I get that. And how has your anger worked out for you? Do you currently have a functioning pwm? For months now you've gone without a pwm and have brought this to WR's attentions countless times and here we are today: still nothing. This is why I said: Just download LP and use it UNTIL WR's works again. Seems simple enough to me.

Here's how it's worked out for me:

I've done enough research to know what my next purchase will be when I get my next anti-malware suite. I certainly will not give my business to a company who have shown themselves to be unresponsive to reports of a non-functioning part of their product.
Really, what would you do? Keep giving your money to them? You go right ahead and do that, if that's how you choose to toss your money away, but I choose to spend more wisely. For me, money is the result of labor for someone else's benefit. That money, I choose to use for MY benefit, and my benefit does not include giving that money to companies who so openly turn their backs on their customers.
Userlevel 3
Badge +11
SO, now I can log in via the PWM toolbar, but no sites are displayed. Still counts as broken.
Userlevel 3
Badge +11
Biiiig sigh...
So, now we know what's actually been going on. While we were wondering why we weren't getting a fix for the Password manager issues, and why we weren't hearing a peep from Webroot about it, it seems that Webroot's management was out selling the company.
I am not encouraged, but, since I've already made my decision regarding Webroot, it's not a big deal for me. I feel somewhat vindicated, though, since it appears that I'm not the only one taking my money and running. Webroot's managers are doing the same.
This is why a broken feature was not a priority.